Incident Manager: Overview
SureCloud’s Incident Management solution helps organisations identify if and when an incident has occurred. It tracks the nature of the incident, the categories and approximate number of Data Subjects and personal data records, as well as the planned investigation and mitigation work to be completed.
The application tracks the sequence of events as they unfold and describes the incident in detail after the fact; recording the participants and locations involved as well as the assets, systems and individuals impacted. Identification of the root causes can be used to highlight effective mitigating controls and reinforce failed controls.
Incident Register
The Incident Register form is an overview of incidents and issues, and automatically creates a detailed incident form when all the prerequisite fields have been completed. The application distinguishes between Issues and Incidents:
Option |
Definition |
Workflow |
Issue |
An event with no discernible impact to either the organisation or any data subjects. |
None. The event is logged with no additional detail beyond the summary provided and key dates & times. |
Incident |
An event that which impacts the organisation and/or any data subjects. |
Incident form generated for the capturing of further details. A Data Breach Report is potentially required as well depending on a risk assessment. |
Adding a new incident is done by clicking the add button in the top left.
The Incident Register has the following fields:
Ref. |
Item |
Description |
1 |
Ref |
This is an automatically generated reference for the row, it is unique across the form, and is chronological based upon when the row was added. |
2 |
Summary |
This is a free text box to provide a description of the incident or issue. |
3 |
Nature |
Select the nature of this Incident from the list: Near Miss (an incident that nearly occurred), First Time (the first occurrence of an incident)or Repeating (an incident that occurs regularly). |
4 |
Initiator |
An initiator can be assigned to an incident using this user select field. |
5 |
Date Notified |
The date the incident was reported. |
6 |
Time Notified |
The time the incident was reported. This time can only be entered in the 24 hours format e.g. 12:35. |
7 |
Type |
Incident or Issue. |
8 |
Date Occurred |
The date the incident occurred. |
9 |
Time Occurred |
The time the incident occurred. This time can only be entered in the 24 hours format e.g. 12:35. |
10 |
Facilitator |
The facilitator, this person will be notified by email when assigned. |
11 |
Variant |
The variant is selected from the variant form, the variants are: Security, Privacy or Health and Safety. Each of these have an associated time objective that affects the deadline. They also change the details form built out for this incident. |
12 |
Deadline |
This is automatically calculated based upon the date and time notified, and the variant time objective. |
13 |
Details |
This button creates the incident form, it is only available if the type is an incident, it is also used to navigate to said form. |
14 |
Severity |
This data is populated from the Details form. |
15 |
Root Cause |
This data is populated from the Details form. |
16 |
Status |
This data is populated from the Details form. |
17 |
Date Closed |
This data is populated from the Details form. |
Next Step: Incident Details Form
Comments